24小时直播推流
最开始是在张大妈上看到有个老哥分享的文章, 使用24小时直播推到b站每月20块钱保底, 所以就大概研究了下, 发现还挺有意思的, 下面就是具体的介绍.
Kplayer官方文档: https://docs.kplayer.net/v0.5.7/quick/install.html
2.20更新: dockerke已正常启动, 上次是配置文件有问题
1. 简易实现版本
硬件: Linux服务器
软件: Kplayer
在这个简单版本中, 使用本地文件作为直播间的推送流进行播放, 因为Kplayer 支持http协议文件, 所以后续计划升级为播放NAS资源(中间尝试了Alist上的资源播放, 但是因为上面的链接不能解码, 所以暂时做成了本地版的).
1. 启动 Kplayer
一开始我是想使用docker启动的, 但是启动数次没有成功, 所以就直接用了本地启动.
- 一键安装
bash
curl -fsSL get.kplayer.net | bash配置config.json 文件
一键安装后进入kplayer 目录新建该文件, 这个文件是Kplayer 的启动配置, 包括资源来源, 推送到哪, 视频播放模式(如循环播放)等其他, 更详细的可以参考官网文档. 因为这里resource 字段支持http 协议, 所以后面可以配置一些在线资源, 也就是进阶版.
json
{
"version": "2.0.0",
"resource": {
"lists": [
"/etc/kplayer/2000.mp4",
"/etc/kplayer/a.mp3"
]
},
"output": {
"lists": [
{
"path": "直播推流地址, 需要换成自己的地址(B站实例在后面1.2章节)"
}
]
}
}- 启动
kplayer 目录下运行下面命令
bash
./kplayer play start如果控制台出现下面日志(图片来自官网, 内容不重要, 主要是格式), 同时没有退出进程, 就表示运行成功

然后到自己的直播间查看是否正常就行. 如果一切正常就可以进行后台运行了, 这样退出终端也不会停止.
bash
# 后台打开
./kplayer play start --daemon
# 关闭后台
./kplayer play stop如果中间有报错
I/O error [-5]- 此时可以看下是不是直播间出问题了, 如关闭
- 格式错误
- 检查
config.json文件是否格式错误
- 检查
1.2 B站推流地址获取
- 进入个人直播中心

按照网页提示打开直播
获取推流地址
下图中A+B 拼接在一起就是推流地址.

